Storage root change.

Featured

Comments

27 comments

  • Osweetman

    Hi Nathan,

    I'm using a Motorola Droid X, and it appears there is no way to change the storage path to anything other than /mnt/sdcard (and subdirectories of such).  And that only works if you choose an existing path (BCN will not create a new parent folder).  I like your idea, but it looks like there is a security feature that severely limits it.

    It seems that most other programs store their data by default on internal memory, and some give you the option to move it to external memory.  Could you change BCN to operate this way?  We probably wouldn't be able to choose the exact storage path, but I would just like to be able to choose between internal and external memory.  And right now on my phone, the only option is external.

    Also, one other suggestion :)  I think this should be posted on http://www.backcountrynavigator.com/forum.  That would seem to be a more visible place for this question.

  • Nathan

    It does not restrict you to subdirectories of the /mnt/sdcard. You can type another valid path. It merely checks that the path exists and is writeable. I think that is reasonable. Changing the path is a rather empty victory if the app stops working.

    But you still haven't discovered what that path is, have you?  Can you see any paths when using Astro Explorer that aren't under /mnt/sdcard?

    I cannot change BCN to use the internal memory without knowing what the path is. If I can find out what the secrets of those other apps are, maybe I can. 

    I could put data in private app space, which means I wouldn't know the path, you couldn't find any files I put there, and they would all get erased during uninstall/reinstall. Android may not let me store a very large set of files there.

  • Osweetman

    OK, I understand where you're coming from, and it sounds like the only option (other than maybe rooting the phone) is to use "private app space".

    I personally would still like to have this option, just because my phone has a huge amount of unused internal storage.  Maybe you could keep external memory as the default and add an option to move it to "private app space"?

    Regarding the issue of discovering internal directories, I'm able to see many of them with Astro, but some might be hidden.  For instance, the /data directory is shown as being empty.  Regardless, none of the internal directories are writable.

  • John Yatchak

    Nathan,

     I have a Samsung Galaxy S - non b randed phone. The external SD card shows up as ' /mnt/sd/external_sd' using 'My Files'. I added a bcnav sub-directory there and it seems to be using the external card fine. I'm in the process of transferring 5GB from internal storage to that location. Initial tests indicate bcnav was storng data there. Once all my stored tiles are moved I'll delete the data from the internal sd card locations.

  • Nathan
    Finally a success story. Thanks this will help others with the Galaxy S.
  • Nathan starr
    I've changed my folder to my external sd card successfully in my captivate and my inspire. I love having all of the topos for the state of WA saved to my phone.
  • Jim Jacobs
    Under settings root storage path,open, change path to /mnt / sdcard2. Don't put in the spaces I have fat fingers
  • Tony Flisch

    I too have a Galaxy S2 and sadly downloaded heaps of Multimap tiles before realising that the Galaxy has this weird storage system, whereby the internal storage is /mnt/sdcard.  I have a 32Gb external card and its path is /mnt/sdcard/external_sd (and not ' /mnt/sd/external_sd' as in John Yatchak's post).  This too explains why none of the apps I have shifted to the external card have actually ended up there!

    Moving the data to the real external card was a nightmare as there are thousands of little files - I ended up doing it piecemeal with my PC as an intermediary.  ( I tried moving the data using a terminal app but it refuses to copy data from one device to another!!)  Now the data are in the new location there, the maps are available, but there is an odd problem whereby as you zoom in to some areas, the map is replaced by the cross within a circle signs.  In some areas zooming further in will take you to a larger scale map - in others nothing.  I suspect in transferring the data something has gone awry and I'd better download it all again - at least now it's now all going in the right place!  I wonder if the tiles already exist it will overwrite or skip?

    Thanks John Yatchack for that post and pointing me in the right direction.

    Love the app by the way

  • Nathan

    Unfortunately, I've heard of a pretty bad bug on the Galaxy S2. Nothing I can do about it but you should be informed.

     

    http://forum.xda-developers.com/showthread.php?t=978012

  • Tony Flisch
    Nathan lm afraid I dont follow that. What effect on your app?
  • Mike schellenberger

    I just changed storage root on my Captivate to the external storage card, BC created it's folder structure in the new location, I then moved  the files from the original/default location and I have my previously 'downloaded' tiles.

    Problem is now that I can't select any more new areas for download. I hit Map Mode, 'Select Areas for Download' the 'select' option is green but I can't draw the rectangle, I can untoggle select and move and retoggle select and still can't draw. The 'Recycle' option gives me the same text message as the Download button ....it tells me how to select an are to then download.

    I am pretty sure I got one select/download cycle in after moving the storage and the failure occurred after trying to add to what I've downloaded.

    ??????

  • Mark Singer53

    Attempting to Transfer files between a Xoom tablet and a MyTouch 4g phone.

    I have been working with Nathan on this but the frustration factor is starting to mount.  After reading these posts, I have truly lost hope.

    There is no standard in the Android industry for defining paths?  My Xoom is lying to me about where it's putting my files?  If so, how will I ever "discover" the path I need to put in BC?  Is it a random process of just typing in paths or is there some science to it?

    This is insane.  May be time to sell my Android stuff and go to IPAD.

     

     

  • Nathan

    Apparently, yes, the Xoom is lying to you.

    From this link,

    https://supportforums.motorola.com/thread/55334?start=15&tstart=0

    Xoom considers /mnt/sdcard to be the internal storage and/mnt/external1 to be the removable sdcard. Yes really.

    But it gets worse.

    Apparently Motorola will only allow preinstalled apps to write to the removable sd card. This means that reconfiguring BCN won't work, because it is looking for a writeable path. 

    Your best option may be to install a file explorer like Astro Explorer,  and then copy /mnt/external1/bcnav/data/yourtripfile.bcn to /mnt/sdcard/bcnav/data directory. (This assumes that link is correct). Then do load existing trip on the xoom, and choose yourtripfile.

    Yes, Android and manufacturers have royally screwed up storage volumes.It seems like some years, ago, it never occurred to someone that there would be more than one storage volume, and it still hasn't.

    I don't know as much about the iPad, but I believe it may not even give users access to the storage volumes.Android could be better if it made sense.

  • Tom Moorhead

    I'm using an Acer Iconia Tab A100, the 7inch tablet.  The storage path that worked for me is /mnt/external_sd 

  • Kirk McKee

    I'm using Droid 3 running Android 2.3.4, found the external SD card path should be set to - /mnt/sdcard-ext

    Good luck!

  • Jemanner

    Running on a Samsung Galaxy Tab 7.7 with Android 3.2.  Evenn though I can access the external SD card with other apps, BCN tell me /mnt/sdcard/extStorages/SdCard is invalid.  In fact, to prove the card is accessible, crearted a "bcn" folder on the external storage card.  Not quite sure I understand Android file structures, as with My Files the path is shown as /Root/extStorages/SdCard.  Yep, have tried this in BCN also.  Help!

  • Steve Kunkel

    No problem with the new Samsung Galaxy Tab 2 7.0. It is menu select to store maps on the extSDcard.

  • Jemanner

    Making progress Nathan, as within BCN I can now select /mnt/sdcard/extStorages/SdCard, but it does not come back and ask if I wish to use this space. On a Samsung Galaxy Tab 7.7 I can use the My Files utility and copy the Tiles folder to the external storage, so it is surely writable. If only I could successfully point BCN to the external media. Something I am doing wrong? I still suspect BCN does not see the rxternal media as accessible.

  • Nathan

    Because some apps can write there doesn't mean that BCN can. MyFiles is a preinstalled app it has special powers. I believe media apps can also.  

    I've told the Android framework people that this is a very stupid idea, but they and manufacturers have somehow got the idea that the removable storage is only for media like photos and music.

    I'd like to help, but I have to concentrate on things I can actually do something about. So far, I can't seem to do anything about this. 

  • Charlie Sidhu
    FYI On Tab 7 Plus upgrading to Ice Cream Sandwich allows BCNav to save maps to ExtStorage! !! I have over 25GB of maps saved on 32GB card!
  • jose manuel ruiz soria
    Hola no conseguia leer mis ficheros de wp y track. Cambie el directorio varias veces hasta que averigue qie ocurria El cuadro de dialogo "cargar viaje existente" no se despliega cuando hay mas de 4 viajes distintos incluso la ventana se ve reducida, se puede solucionar esto'?? Gracias y sorry i dont speek inglis
  • jose manuel ruiz soria
    Hola no conseguia leer mis ficheros de wp y track. Cambie el directorio varias veces hasta que averigue qie ocurria El cuadro de dialogo "cargar viaje existente" no se despliega cuando hay mas de 4 viajes distintos incluso la ventana se ve reducida, se puede solucionar esto'?? Gracias y sorry i dont speek inglis
  • Carol

    Nathan, I appreciate greatly that you added to BCNav the external storage option--much more so now that I've got a newer (although still old) Motorola Bionic with a kind of crazy storage set-up. But choosing the external SD card does seem to have worked. I'm REALLY glad, as I too have many, many Gb's of downloaded map tiles to put there.  I already had the phone in hand when I began to read of the problems owners were having actually accessing/using their large SD cards, which could have been a dealer breaker for me.  But it seems solved, and I appreciate all the comments from users of other devices and their experiences.

    Carol

  • Jemanner

    Thank you Nathan! It works! The long awaited capability has arrived. I also just upgraded to Ice Cream Sandwich, and now can download maps to the external SD card. This is night and day for me, as it takes a LOT of USGS GIS maps on some of our long trips. If the day comes to purchase a new tablet, it will certainly have the external SD card option (of which many tablets do not)

  • Tomsteinbrink

    Hi Nathan, this feature was working on my GS2. However, I recently upgraded to the GS4 and while I can change the bcnav folder to a folder I created on my external SD, once I do the program will no longer display or download maps.

    For example, if I keep the storage path to default, I can select US Topo Aerial Imagery and the map will download and display quickly as normal.  As soon as I change the storage path, reboot the app, the map will no longer display.  Even if I try selecting a new map layer, it never displays.  As soon as I switch the storage path back to default - the map will download and display. Any ideas? BCNav seems to recognize that the sd card has 20 GB open on it.

  • Nathan

    That wasn't our change. Samsung broke it with their 4.4 update, so that we can't write to the card. We are looking for any workaround, but be sure and voice your displeasure to Samsung.

  • Tomsteinbrink

    Ah, lovely.  Thanks for the fast response!

Please sign in to leave a comment.